Back to overview
Degraded
Tread Horizon platform experiencing a temporary service interruption
Apr 07 at 07:42am EDT
Affected services
Horizon Web Application
Resolved
Apr 07 at 03:05pm EDT
We have resolved the April 7th Incident at 12:05pm PT
Affected services
Horizon Web Application
Created
Apr 07 at 07:42am EDT
The Tread Horizon platform is experiencing a temporary service interruption. This is affecting the ability to access the platform for some clients. Our team is currently working to restore our service as soon as possible.
Affected services
Horizon Web Application